Host latency
Incident Report for Boat
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 17:27 UTC
Identified
The issue is currently our host is having some latency issues. These should resolve themself in due time.
Posted Feb 26, 2021 - 16:21 UTC